Nagios XI is prone to a cross-site scripting vulnerability because it fails to properly sanitize user-supplied input.

An attacker may leverage these issues to execute arbitrary script code in the browser of an unsuspecting user in the context of the affected site. This may allow the attacker to steal cookie-based authentication credentials and to launch other attacks.

Versions prior to Nagios XI 5.5.4 are vulnerable.

Information

Bugtraq ID: 109116

Class: Input Validation Error

CVE: CVE-2018-17147

Remote: Yes

Local: No

Published: Jul 10 2019 12:00AM

Updated: Jul 10 2019 12:00AM

Credit: Nathan Jones

Vulnerable: Nagios Nagios XI 5.5.3
Nagios Nagios XI 5.5.2
Nagios Nagios XI 5.5.1
Nagios Nagios XI 5.5
Nagios Nagios XI 5.4
Nagios Nagios XI 5.3
Nagios Nagios XI 5.2
Nagios Nagios XI 2012R2.7
Nagios Nagios XI 2012R2.6
Nagios Nagios XI 2012R2.5
Nagios Nagios XI 2012R2.4 B
Nagios Nagios XI 2012R2.4
Nagios Nagios XI 2012R2.3
Nagios Nagios XI 2012R2.2
Nagios Nagios XI 2012R2.1
Nagios Nagios XI 2012R2.0
Nagios Nagios XI 2012R1.9
Nagios Nagios XI 2012R1.8
Nagios Nagios XI 2012R1.7
Nagios Nagios XI 2012R1.6
Nagios Nagios XI 2012R1.5b
Nagios Nagios XI 2012R1.5
Nagios Nagios XI 2012R1.4
Nagios Nagios XI 2012R1.3
Nagios Nagios XI 2012R1.2
Nagios Nagios XI 2012R1.1
Nagios Nagios XI 2012R1.0
Nagios Nagios XI 2012 Rc4
Nagios Nagios XI 2012 Rc3
Nagios Nagios XI 2012 Rc2
Nagios Nagios XI 2011R3.0
Nagios Nagios XI 2011R2.4
Nagios Nagios XI 2011R1.9
Nagios Nagios XI 2011R1.2
Nagios Nagios XI 2009RC3
Nagios Nagios XI 2009R1.3C
Nagios Nagios XI 2009R1.3B
Nagios Nagios XI 2009R1.3
Nagios Nagios XI 2009R1.2D
Nagios Nagios XI 2009R1.2C
Nagios Nagios XI 2009R1.2B
Nagios Nagios XI 2009R1.2
Nagios Nagios XI 2009R1.1H
Nagios Nagios XI 2009R1.1G
Nagios Nagios XI 2009R1.1C
Nagios Nagios XI 2009R1.1A
Nagios Nagios XI 2009R1

Not Vulnerable: Nagios Nagios XI 5.5.4

Exploit

Attackers can exploit these issues by enticing an unsuspecting user to follow a malicious URI.

References: